Yamaha 10G SWR2310-28GT/18GT/10G Command Reference - Page 254

Set pre-marking TOS precedence

Page 254 highlights

254 | Command Reference | Traffic control [Note] In order to execute this command, QoS must be enabled. Pre-marking cannot be used in conjunction with the set egress queue function. [Example] Make the following settings for received frames of LAN port #1 • Permit traffic from the 10.1.0.0 network • Change the classified traffic class to the CoS value "2" [Traffic class definition] SWR2310(config)#access-list 1 permit any 10.1.0.0 0.0.255.255 any SWR2310(config)#class-map class1 SWR2310(config-cmap)#match access-list 1 SWR2310(config-cmap)#exit [Policy settings] SWR2310(config)#policy-map policy1 SWR2310(config-pmap)#class class1 SWR2310(config-pmap-c)#set cos 2 SWR2310(config-pmap-c)#exit SWR2310(config-pmap)#exit SWR2310(config)#interface port1.1 SWR2310(config-if)#service-policy input policy1 9.2.24 Set pre-marking (TOS precedence) [Syntax] set ip-precedence value no set ip-precedence [Parameter] value : TOS precedence to specify by pre-marking [Input mode] policy map class mode [Description] Changes the value of the IP header's TOS precedence field of the classified traffic class to the specified TOS value. In addition, reassign the egress queue according to the egress queue ID table that corresponds to the trust mode. If this is executed with the "no" syntax, pre-marking processing of the TOS precedence corresponding to the traffic class is removed. [Note] In order to execute this command, QoS must be enabled. Pre-marking cannot be used in conjunction with the set egress queue function. [Example] Make the following settings for received frames of LAN port #1 • Permit traffic from the 10.1.0.0 network • Change the classified traffic class to TOS precedence "5". [Traffic class definition] SWR2310(config)#access-list 1 permit any 10.1.0.0 0.0.255.255 any SWR2310(config)#class-map class1 SWR2310(config-cmap)#match access-list 1 SWR2310(config-cmap)#exit [Policy settings] SWR2310(config)#policy-map policy1 SWR2310(config-pmap)#class class1 SWR2310(config-pmap-c)#set ip-precedence 5 SWR2310(config-pmap-c)#exit SWR2310(config-pmap)#exit SWR2310(config)#interface port1.1 SWR2310(config-if)#service-policy input policy1

  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52
  • 53
  • 54
  • 55
  • 56
  • 57
  • 58
  • 59
  • 60
  • 61
  • 62
  • 63
  • 64
  • 65
  • 66
  • 67
  • 68
  • 69
  • 70
  • 71
  • 72
  • 73
  • 74
  • 75
  • 76
  • 77
  • 78
  • 79
  • 80
  • 81
  • 82
  • 83
  • 84
  • 85
  • 86
  • 87
  • 88
  • 89
  • 90
  • 91
  • 92
  • 93
  • 94
  • 95
  • 96
  • 97
  • 98
  • 99
  • 100
  • 101
  • 102
  • 103
  • 104
  • 105
  • 106
  • 107
  • 108
  • 109
  • 110
  • 111
  • 112
  • 113
  • 114
  • 115
  • 116
  • 117
  • 118
  • 119
  • 120
  • 121
  • 122
  • 123
  • 124
  • 125
  • 126
  • 127
  • 128
  • 129
  • 130
  • 131
  • 132
  • 133
  • 134
  • 135
  • 136
  • 137
  • 138
  • 139
  • 140
  • 141
  • 142
  • 143
  • 144
  • 145
  • 146
  • 147
  • 148
  • 149
  • 150
  • 151
  • 152
  • 153
  • 154
  • 155
  • 156
  • 157
  • 158
  • 159
  • 160
  • 161
  • 162
  • 163
  • 164
  • 165
  • 166
  • 167
  • 168
  • 169
  • 170
  • 171
  • 172
  • 173
  • 174
  • 175
  • 176
  • 177
  • 178
  • 179
  • 180
  • 181
  • 182
  • 183
  • 184
  • 185
  • 186
  • 187
  • 188
  • 189
  • 190
  • 191
  • 192
  • 193
  • 194
  • 195
  • 196
  • 197
  • 198
  • 199
  • 200
  • 201
  • 202
  • 203
  • 204
  • 205
  • 206
  • 207
  • 208
  • 209
  • 210
  • 211
  • 212
  • 213
  • 214
  • 215
  • 216
  • 217
  • 218
  • 219
  • 220
  • 221
  • 222
  • 223
  • 224
  • 225
  • 226
  • 227
  • 228
  • 229
  • 230
  • 231
  • 232
  • 233
  • 234
  • 235
  • 236
  • 237
  • 238
  • 239
  • 240
  • 241
  • 242
  • 243
  • 244
  • 245
  • 246
  • 247
  • 248
  • 249
  • 250
  • 251
  • 252
  • 253
  • 254
  • 255
  • 256
  • 257
  • 258
  • 259
  • 260
  • 261
  • 262
  • 263
  • 264
  • 265
  • 266
  • 267
  • 268
  • 269
  • 270
  • 271
  • 272
  • 273
  • 274
  • 275
  • 276
  • 277
  • 278

[Note]
In order to execute this command, QoS must be enabled.
Pre-marking cannot be used in conjunction with the set egress queue function.
[Example]
Make the following settings for received frames of LAN port #1
Permit traffic from the 10.1.0.0 network
Change the classified traffic class to the CoS value "2"
[Traffic class definition]
SWR2310(config)#access-list 1 permit any 10.1.0.0 0.0.255.255 any
SWR2310(config)#class-map class1
SWR2310(config-cmap)#match access-list 1
SWR2310(config-cmap)#exit
[Policy settings]
SWR2310(config)#policy-map policy1
SWR2310(config-pmap)#class class1
SWR2310(config-pmap-c)#set cos 2
SWR2310(config-pmap-c)#exit
SWR2310(config-pmap)#exit
SWR2310(config)#interface port1.1
SWR2310(config-if)#service-policy input policy1
9.2.24 Set pre-marking (TOS precedence)
[Syntax]
set
ip-precedence
value
no
set
ip-precedence
[Parameter]
value
:
<0 - 7>
TOS precedence to specify by pre-marking
[Input mode]
policy map class mode
[Description]
Changes the value of the IP header's TOS precedence field of the classified traffic class to the specified TOS value. In addition,
reassign the egress queue according to the egress queue ID table that corresponds to the trust mode.
If this is executed with the "no" syntax, pre-marking processing of the TOS precedence corresponding to the traffic class is
removed.
[Note]
In order to execute this command, QoS must be enabled.
Pre-marking cannot be used in conjunction with the set egress queue function.
[Example]
Make the following settings for received frames of LAN port #1
Permit traffic from the 10.1.0.0 network
Change the classified traffic class to TOS precedence "5".
[Traffic class definition]
SWR2310(config)#access-list 1 permit any 10.1.0.0 0.0.255.255 any
SWR2310(config)#class-map class1
SWR2310(config-cmap)#match access-list 1
SWR2310(config-cmap)#exit
[Policy settings]
SWR2310(config)#policy-map policy1
SWR2310(config-pmap)#class class1
SWR2310(config-pmap-c)#set ip-precedence 5
SWR2310(config-pmap-c)#exit
SWR2310(config-pmap)#exit
SWR2310(config)#interface port1.1
SWR2310(config-if)#service-policy input policy1
254
| Command Reference | Traffic control