Cisco SGE2000 Software Configuration Guide - Page 28

fex associate, shutdown, Examples - 24 port

Page 28 highlights

Associating a Fabric Extender to a Fabric Interface Configuring the Fabric Extender Examples This example shows how to associate the Fabric Extender to a port channel interface on the parent device: switch# configure terminal switch(config)# interface ethernet 1/28 switch(config-if)# channel-group 4 switch(config-if)# no shutdown switch(config-if)# exit switch(config)# interface ethernet 1/29 switch(config-if)# channel-group 4 switch(config-if)# no shutdown switch(config-if)# exit switch(config)# interface ethernet 1/30 switch(config-if)# channel-group 4 switch(config-if)# no shutdown switch(config-if)# exit switch(config)# interface ethernet 1/31 switch(config-if)# channel-group 4 switch(config-if)# no shutdown switch(config-if)# exit switch(config)# interface port-channel 4 switch(config-if)# switchport switch(config-if)# switchport mode fex-fabric switch(config-if)# fex associate 101 Tip As a best practice, only enter the fex associate command from the port channel interface, not from the physical interface. If you try to associate a physical port to a FEX before that physical port is joined to a port channel, the physical port moves to the err-disable state and the Cisco Nexus 7000 series device does not communicate with the FEX on that link. You must enter the shutdown command and the no shutdown command on the Ethernet interface (not the port channel interface) to clear the err-disable state and bring the link up. (Note that this does not apply if the configuration is performed prior to cabling.) Note When adding physical interfaces to port channels, all configurations on the port channel and physical interface must match. This example shows how to display the association of the Fabric Extender and the parent device: switch# show interface port-channel 4 fex-intf Fabric FEX Interface Interfaces Po4 Eth101/1/48 Eth101/1/47 Eth101/1/46 Eth101/1/44 Eth101/1/43 Eth101/1/42 Eth101/1/40 Eth101/1/39 Eth101/1/38 Eth101/1/36 Eth101/1/35 Eth101/1/34 Eth101/1/32 Eth101/1/31 Eth101/1/30 Eth101/1/28 Eth101/1/27 Eth101/1/26 Eth101/1/24 Eth101/1/23 Eth101/1/22 Eth101/1/20 Eth101/1/19 Eth101/1/18 Eth101/1/16 Eth101/1/15 Eth101/1/14 Eth101/1/12 Eth101/1/11 Eth101/1/10 Eth101/1/8 Eth101/1/7 Eth101/1/6 Eth101/1/4 Eth101/1/3 Eth101/1/2 Eth101/1/45 Eth101/1/41 Eth101/1/37 Eth101/1/33 Eth101/1/29 Eth101/1/25 Eth101/1/21 Eth101/1/17 Eth101/1/13 Eth101/1/9 Eth101/1/5 Eth101/1/1 Cisco Nexus 2000 Series NX-OS Fabric Extender Software Configuration Guide 18 OL-25816-02

  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46

Examples
This example shows how to associate the Fabric Extender to a port channel interface on the parent device:
switch#
configure terminal
switch(config)#
interface ethernet 1/28
switch(config-if)#
channel-group 4
switch(config-if)#
no shutdown
switch(config-if)#
exit
switch(config)#
interface ethernet 1/29
switch(config-if)#
channel-group 4
switch(config-if)#
no shutdown
switch(config-if)#
exit
switch(config)#
interface ethernet 1/30
switch(config-if)#
channel-group 4
switch(config-if)#
no shutdown
switch(config-if)#
exit
switch(config)#
interface ethernet 1/31
switch(config-if)#
channel-group 4
switch(config-if)#
no shutdown
switch(config-if)#
exit
switch(config)#
interface port-channel 4
switch(config-if)#
switchport
switch(config-if)#
switchport mode fex-fabric
switch(config-if)#
fex associate 101
As a best practice, only enter the
fex associate
command from the port channel interface, not from the
physical interface.
If you try to associate a physical port to a FEX before that physical port is joined to a port channel, the
physical port moves to the err-disable state and the Cisco Nexus 7000 series device does not communicate
with the FEX on that link. You must enter the
shutdown
command and the
no shutdown
command on
the Ethernet interface (not the port channel interface) to clear the err-disable state and bring the link up.
(Note that this does not apply if the configuration is performed prior to cabling.)
Tip
When adding physical interfaces to port channels, all configurations on the port channel and physical
interface must match.
Note
This example shows how to display the association of the Fabric Extender and the parent device:
switch#
show interface port-channel 4 fex-intf
Fabric
FEX
Interface
Interfaces
---------------------------------------------------
Po4
Eth101/1/48
Eth101/1/47
Eth101/1/46
Eth101/1/45
Eth101/1/44
Eth101/1/43
Eth101/1/42
Eth101/1/41
Eth101/1/40
Eth101/1/39
Eth101/1/38
Eth101/1/37
Eth101/1/36
Eth101/1/35
Eth101/1/34
Eth101/1/33
Eth101/1/32
Eth101/1/31
Eth101/1/30
Eth101/1/29
Eth101/1/28
Eth101/1/27
Eth101/1/26
Eth101/1/25
Eth101/1/24
Eth101/1/23
Eth101/1/22
Eth101/1/21
Eth101/1/20
Eth101/1/19
Eth101/1/18
Eth101/1/17
Eth101/1/16
Eth101/1/15
Eth101/1/14
Eth101/1/13
Eth101/1/12
Eth101/1/11
Eth101/1/10
Eth101/1/9
Eth101/1/8
Eth101/1/7
Eth101/1/6
Eth101/1/5
Eth101/1/4
Eth101/1/3
Eth101/1/2
Eth101/1/1
Cisco Nexus 2000 Series NX-OS Fabric Extender Software Configuration Guide
18
OL-25816-02
Configuring the Fabric Extender
Associating a Fabric Extender to a Fabric Interface