Cisco SGE2000 Software Configuration Guide - Page 34

Configuring a FEX with a Layer 3 Host Interface - trunk

Page 34 highlights

Configuration Examples Configuring the Fabric Extender Configuring a FEX with a Layer 3 Host Interface This example shows how to configure a Fabric Extender with a Layer 3 host interface (at the interface level, subinterface level, port channel level, and port channel subinterface level): Layer 3 Configuration Layer 3 Sub-interface Configuration config t interface ethernet 101/1/1 no switchport ip address 192.0.1.1/24 Mtu 9000 no shutdown config t interface ethernet 101/1/1.12 ip address 192.0.2.1/24 encapsulation dot1Q 12 mtu 850 no shutdown Layer 3 Host Interface Port Channel Configuration config t interface ethernet 101/1/1-2 no switchport channel-group 12 no shutdown interface port-channel 12 ip address 192.0.3.1/24 mtu 2000 no shutdown Layer 3 Host Interface Port Channel Sub-interface Configuration config t interface ethernet 101/1/1-2 no switchport channel-group 12 no shutdown interface port-channel 12.14 ip address 192.0.4.1/24 encapsulation dot1Q 14 mtu 1700 no shutdown Note The VLAN used in the Layer 3 host interface (HIF) or host interface port channel (HIFPC) subinterface has only local significance to its parent interface. The same VLAN ID can be reused between Layer 3 subinterfaces in the same switch or VDC. Configuring a Host Interface in a vPC Topology Connected to Two FEXs This example shows how to configure a host vPC with a FEX (host vPC attached to 2 different FEXs): Switch 1 Configuration Switch 2 Configuration config t feature lacp int e101/1/1-2 channel-group 12 mode active no shutdown Int port-channel10 switchport switchport mode trunk switchport trunk allowed vlan 1-20 vpc 10 config t feature lacp int e101/1/1-2 channel-group 12 mode active no shutdown Int port-channel10 switchport switchport mode trunk switchport trunk allowed vlan 1-20 vpc 10 Cisco Nexus 2000 Series NX-OS Fabric Extender Software Configuration Guide 24 OL-25816-02

  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46

Configuring a FEX with a Layer 3 Host Interface
This example shows how to configure a Fabric Extender with a Layer 3 host interface (at the interface level,
subinterface level, port channel level, and port channel subinterface level):
Layer 3 Sub-interface Configuration
Layer 3 Configuration
config t
interface ethernet 101/1/1.12
ip address 192.0.2.1/24
encapsulation dot1Q 12
mtu 850
no shutdown
config t
interface ethernet 101/1/1
no switchport
ip address 192.0.1.1/24
Mtu 9000
no shutdown
Layer 3 Host Interface Port Channel Sub-interface
Configuration
Layer 3 Host Interface Port Channel Configuration
config t
interface ethernet 101/1/1-2
no switchport
channel-group 12
no shutdown
interface port-channel 12.14
ip address 192.0.4.1/24
encapsulation dot1Q 14
mtu 1700
no shutdown
config t
interface ethernet 101/1/1-2
no switchport
channel-group 12
no shutdown
interface port-channel 12
ip address 192.0.3.1/24
mtu 2000
no shutdown
The VLAN used in the Layer 3 host interface (HIF) or host interface port channel (HIFPC) subinterface
has only local significance to its parent interface. The same VLAN ID can be reused between Layer 3
subinterfaces in the same switch or VDC.
Note
Configuring a Host Interface in a vPC Topology Connected to Two FEXs
This example shows how to configure a host vPC with a FEX (host vPC attached to 2 different FEXs):
Switch 2 Configuration
Switch 1 Configuration
config t
feature lacp
int e101/1/1-2
channel-group 12 mode active
no shutdown
Int port-channel10
switchport
switchport mode trunk
switchport trunk allowed vlan 1-20
vpc 10
config t
feature lacp
int e101/1/1-2
channel-group 12 mode active
no shutdown
Int port-channel10
switchport
switchport mode trunk
switchport trunk allowed vlan 1-20
vpc 10
Cisco Nexus 2000 Series NX-OS Fabric Extender Software Configuration Guide
24
OL-25816-02
Configuring the Fabric Extender
Configuration Examples