Dell PowerStore 3000X EMC PowerStore Network Configuration Guide for PowerSwit - Page 55

Con port interfaces for PowerStore X model node connectivity

Page 55 highlights

Configure port interfaces for PowerStore X model node connectivity You configure the port interfaces between the PowerStore X model nodes and the ToR switches. Steps 1. Establish a terminal connection to the switch to the first ToR switch (Switch1) 2. Enter global configuration mode. configure terminal 3. Configure allowed VLANs and the native VLAN for Node A port 0 and ToR switch 1. NOTE: For iSCSI best practices, it is recommended to disable flow control as demonstrated below. interface ethernet 1/1/1 description Node-A-Port_0 no shutdown switchport mode trunk switchport access vlan 1 switchport trunk allowed vlan 100,200,400 flowcontrol receive off flowcontrol transmit off spanning-tree port type edge exit 4. Repeat steps on switch 1 for Node B, port 1, as demonstrated below. NOTE: For iSCSI best practices, it is recommended to disable flow control as demonstrated below. configure terminal interface ethernet 1/1/54 description Node-B-Port-1 no shutdown switchport mode trunk switchport access vlan 1 switchport trunk allowed vlan 100,200,400 flowcontrol receive off flowcontrol transmit off spanning-tree port type edge exit 5. Repeat steps on switch 2 connectivity to Node A Port 0 and Node B Port 1 as demonstrated below. While configuring Switch 2, note that the ethernet interfaces are reversed. Ethernet interface 1 is configured on Node-BPort-1 and interface 54 is configured on Node-A-Port-0 as demonstrated below. Table 18. Code sample configuring port interfaces on the ToR switches Switch 1 connectivity to Node A Port 0 Switch 2 connectivity to Node A Port 1 configure terminal interface ethernet 1/1/1 description Node-A-Port-0 no shutdown switchport mode trunk switchport access vlan 1 switchport trunk allowed vlan 100,200,400 flowcontrol receive off flowcontrol transmit off spanning-tree port type edge exit configure terminal interface ethernet 1/1/1 description Node-A-Port-1 no shutdown switchport mode trunk switchport access vlan 1 switchport trunk allowed vlan 100,200,400 flowcontrol receive off flowcontrol transmit off spanning-tree port type edge exit Switch 1 connectivity to Node B Port 1 Switch 2 connectivity to Node B Port 0 PowerStore X model: Configure switches 55

  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52
  • 53
  • 54
  • 55
  • 56
  • 57
  • 58
  • 59
  • 60
  • 61
  • 62
  • 63
  • 64
  • 65
  • 66
  • 67
  • 68
  • 69
  • 70
  • 71
  • 72
  • 73
  • 74
  • 75
  • 76
  • 77
  • 78
  • 79
  • 80
  • 81
  • 82
  • 83
  • 84
  • 85
  • 86
  • 87
  • 88
  • 89
  • 90
  • 91
  • 92
  • 93

Configure port interfaces for PowerStore X model node
connectivity
You configure the port interfaces between the PowerStore X model nodes and the ToR switches.
Steps
1.
Establish a terminal connection to the switch
to the first ToR switch (Switch1)
2.
Enter global configuration mode.
configure terminal
3.
Configure allowed VLANs and the native VLAN for Node A port 0 and ToR switch 1.
NOTE:
For iSCSI best practices, it is recommended to disable flow control as demonstrated below.
interface ethernet 1/1/1
description Node-A-Port_0
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 100,200,400
flowcontrol receive off
flowcontrol transmit off
spanning-tree port type edge
exit
4.
Repeat steps on switch 1 for Node B, port 1, as demonstrated below.
NOTE:
For iSCSI best practices, it is recommended to disable flow control as demonstrated below.
configure terminal
interface ethernet 1/1/54
description Node-B-Port-1
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 100,200,400
flowcontrol receive off
flowcontrol transmit off
spanning-tree port type edge
exit
5.
Repeat steps on switch 2 connectivity to Node A Port 0 and Node B Port 1 as demonstrated below.
While configuring Switch 2, note that the ethernet interfaces are reversed. Ethernet interface 1 is configured on Node-B-
Port-1 and interface 54 is configured on Node-A-Port-0 as demonstrated below.
Table 18. Code sample configuring port interfaces on the ToR switches
Switch 1 connectivity to Node A Port 0
Switch 2 connectivity to Node A Port 1
configure terminal
interface ethernet 1/1/1
description Node-A-Port-0
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 100,200,400
flowcontrol receive off
flowcontrol transmit off
spanning-tree port type edge
exit
configure terminal
interface ethernet 1/1/1
description Node-A-Port-1
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 100,200,400
flowcontrol receive off
flowcontrol transmit off
spanning-tree port type edge
exit
Switch 1 connectivity to Node B Port 1
Switch 2 connectivity to Node B Port 0
PowerStore X model: Configure switches
55