Cisco CISCO876-SEC-I-K9 Configuration Guide - Page 87

crypto map, ip access-list {standard | extended}, permit, Step 5

Page 87 highlights

Chapter 7 Configuring VPNs Using an IPSec Tunnel and Generic Routing Encapsulation Configuration Example Step 5 Command or Action crypto map map-name Example: Router(config-if)# crypto map static-map Router(config-if)# Step 6 exit Example: Router(config-if)# exit Router(config)# Step 7 ip access-list {standard | extended} access-list-name Example: Router(config)# ip access-list extended vpnstatic1 Router(config-acl)# Step 8 permit protocol source source-wildcard destination destination-wildcard Example: Router(config-acl)# permit gre host 192.168.100.1 host 192.168.101.1 Router(config-acl)# Step 9 exit Example: Router(config-acl)# exit Router(config)# Purpose Assigns a crypto map to the tunnel. Note Dynamic routing or static routes to the tunnel interface must be configured to establish connectivity between the sites. See the Cisco IOS Security Configuration Guide for details. Exits interface configuration mode, and returns to global configuration mode. Enters ACL configuration mode for the named ACL that is used by the crypto map. Specifies that only GRE traffic is permitted on the outbound interface. Returns to global configuration mode. Configuration Example The following configuration example shows a portion of the configuration file for a VPN using a GRE tunnel scenario described in the preceding sections. ! aaa new-model ! aaa authentication login rtr-remote local aaa authorization network rtr-remote local aaa session-id common ! username cisco password 0 cisco ! interface tunnel 1 ip address 10.62.1.193 255.255.255.252 OL-5332-01 Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide 7-9

  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52
  • 53
  • 54
  • 55
  • 56
  • 57
  • 58
  • 59
  • 60
  • 61
  • 62
  • 63
  • 64
  • 65
  • 66
  • 67
  • 68
  • 69
  • 70
  • 71
  • 72
  • 73
  • 74
  • 75
  • 76
  • 77
  • 78
  • 79
  • 80
  • 81
  • 82
  • 83
  • 84
  • 85
  • 86
  • 87
  • 88
  • 89
  • 90
  • 91
  • 92
  • 93
  • 94
  • 95
  • 96
  • 97
  • 98
  • 99
  • 100
  • 101
  • 102
  • 103
  • 104
  • 105
  • 106
  • 107
  • 108
  • 109
  • 110
  • 111
  • 112
  • 113
  • 114
  • 115
  • 116
  • 117
  • 118
  • 119
  • 120
  • 121
  • 122
  • 123
  • 124
  • 125
  • 126
  • 127
  • 128
  • 129
  • 130
  • 131
  • 132
  • 133
  • 134
  • 135
  • 136
  • 137
  • 138
  • 139
  • 140
  • 141
  • 142
  • 143
  • 144
  • 145
  • 146
  • 147
  • 148
  • 149
  • 150
  • 151
  • 152
  • 153
  • 154
  • 155
  • 156
  • 157
  • 158
  • 159
  • 160
  • 161
  • 162
  • 163
  • 164
  • 165
  • 166
  • 167
  • 168
  • 169
  • 170
  • 171
  • 172
  • 173
  • 174
  • 175
  • 176
  • 177
  • 178
  • 179
  • 180
  • 181
  • 182
  • 183
  • 184
  • 185
  • 186
  • 187
  • 188
  • 189
  • 190
  • 191
  • 192
  • 193
  • 194
  • 195
  • 196

7-9
Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
OL-5332-01
Chapter 7
Configuring VPNs Using an IPSec Tunnel and Generic Routing Encapsulation
Configuration Example
Configuration Example
The following configuration example shows a portion of the configuration file for a VPN using a GRE
tunnel scenario described in the preceding sections.
!
aaa new-model
!
aaa authentication login rtr-remote local
aaa authorization network rtr-remote local
aaa session-id common
!
username cisco password 0 cisco
!
interface tunnel 1
ip address 10.62.1.193 255.255.255.252
Step 5
crypto map
map-name
Example:
Router(config-if)#
crypto map
static-map
Router(config-if)#
Assigns a crypto map to the tunnel.
Note
Dynamic routing or static routes to the
tunnel interface must be configured to
establish connectivity between the sites.
See the
Cisco IOS Security Configuration
Guide
for details.
Step 6
exit
Example:
Router(config-if)#
exit
Router(config)#
Exits interface configuration mode, and returns to
global configuration mode.
Step 7
ip access-list {standard | extended}
access-list-name
Example:
Router(config)#
ip access-list extended
vpnstatic1
Router(config-acl)#
Enters ACL configuration mode for the named
ACL that is used by the crypto map.
Step 8
permit
protocol
source source-wildcard
destination destination-wildcard
Example:
Router(config-acl)#
permit
gre host
192.168.100.1 host 192.168.101.1
Router(config-acl)#
Specifies that only GRE traffic is permitted on the
outbound interface.
Step 9
exit
Example:
Router(config-acl)#
exit
Router(config)#
Returns to global configuration mode.
Command or Action
Purpose