Dell S5148F-ON OS10 Enterprise Edition User Guide Release 10.3.2E-R1 - Page 37

Linux shell commands

Page 37 highlights

You can use vi or any other editor to create the .cmd file, then use the batch command to execute the file. To execute a series of commands in a file in batch mode (non-interactive processing), use the batch command. OS10 automatically commits all commands in a batch file - you do not have to enter the commit command. • Create a batch file (b.cmd) on a remote device by entering a series of commands. interface ethernet 1/1/4 no switchport ip address 172.17.4.1/24 no shutdown • Copy the command file on the remote device to your switch, such as to your home directory. OS10# copy scp://os10user:[email protected]:/home/os10/b.cmd home://b.cmd OS10# dir home Directory contents for folder: home Date (modified) Size (bytes) 2017-02-15T19:25:35Z 77 b.cmd ... Name • Execute the batch file using the batch command in EXEC mode. OS10# batch b.cmd OS10# Feb 15 19:26:1: %Dell EMC (OS10) %Node.1-Unit.1:PRI:OS10 %log-notice:IP_ADDRESS_ADD: IP Address add is successful.:IP 172.17.4.1/24 added successfully • (Optional) Verify the new commands in the running configuration. OS10# show running-configuration interface ethernet 1/1/4 ! interface ethernet1/1/4 ip address 172.17.4.1/24 no switchport no shutdown Linux shell commands You can execute a single command, or a series of commands using a batch file from the Linux shell. • Use the -c option to run a single command. admin@OS10:/opt/dell/os10/bin$ clish -c "show version" New user admin logged in at session 10 Dell EMC Networking OS10 Enterprise Copyright (c) 1999-2018 by Dell Inc. All Rights Reserved. OS Version: 10.3.2E(X) Build Version: 10.3.2E(X.433) Build Time: 2018-01-03T11:57:14-0800 System Type: S5148F-ON Architecture: x86_64 Up Time: 1 day 05:34:06 User admin logged out at session 10 admin@OS10:/opt/dell/os10/bin$ • Use the -B option along with a batch file to execute a series of commands. configure terminal router bgp 100 neighbor 100.1.1.1 remote-as 104 no shutdown Getting Started 37

  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52
  • 53
  • 54
  • 55
  • 56
  • 57
  • 58
  • 59
  • 60
  • 61
  • 62
  • 63
  • 64
  • 65
  • 66
  • 67
  • 68
  • 69
  • 70
  • 71
  • 72
  • 73
  • 74
  • 75
  • 76
  • 77
  • 78
  • 79
  • 80
  • 81
  • 82
  • 83
  • 84
  • 85
  • 86
  • 87
  • 88
  • 89
  • 90
  • 91
  • 92
  • 93
  • 94
  • 95
  • 96
  • 97
  • 98
  • 99
  • 100
  • 101
  • 102
  • 103
  • 104
  • 105
  • 106
  • 107
  • 108
  • 109
  • 110
  • 111
  • 112
  • 113
  • 114
  • 115
  • 116
  • 117
  • 118
  • 119
  • 120
  • 121
  • 122
  • 123
  • 124
  • 125
  • 126
  • 127
  • 128
  • 129
  • 130
  • 131
  • 132
  • 133
  • 134
  • 135
  • 136
  • 137
  • 138
  • 139
  • 140
  • 141
  • 142
  • 143
  • 144
  • 145
  • 146
  • 147
  • 148
  • 149
  • 150
  • 151
  • 152
  • 153
  • 154
  • 155
  • 156
  • 157
  • 158
  • 159
  • 160
  • 161
  • 162
  • 163
  • 164
  • 165
  • 166
  • 167
  • 168
  • 169
  • 170
  • 171
  • 172
  • 173
  • 174
  • 175
  • 176
  • 177
  • 178
  • 179
  • 180
  • 181
  • 182
  • 183
  • 184
  • 185
  • 186
  • 187
  • 188
  • 189
  • 190
  • 191
  • 192
  • 193
  • 194
  • 195
  • 196
  • 197
  • 198
  • 199
  • 200
  • 201
  • 202
  • 203
  • 204
  • 205
  • 206
  • 207
  • 208
  • 209
  • 210
  • 211
  • 212
  • 213
  • 214
  • 215
  • 216
  • 217
  • 218
  • 219
  • 220
  • 221
  • 222
  • 223
  • 224
  • 225
  • 226
  • 227
  • 228
  • 229
  • 230
  • 231
  • 232
  • 233
  • 234
  • 235
  • 236
  • 237
  • 238
  • 239
  • 240
  • 241
  • 242
  • 243
  • 244
  • 245
  • 246
  • 247
  • 248
  • 249
  • 250
  • 251
  • 252
  • 253
  • 254
  • 255
  • 256
  • 257
  • 258
  • 259
  • 260
  • 261
  • 262
  • 263
  • 264
  • 265
  • 266
  • 267
  • 268
  • 269
  • 270
  • 271
  • 272
  • 273
  • 274
  • 275
  • 276
  • 277
  • 278
  • 279
  • 280
  • 281
  • 282
  • 283
  • 284
  • 285
  • 286
  • 287
  • 288
  • 289
  • 290
  • 291
  • 292
  • 293
  • 294
  • 295
  • 296
  • 297
  • 298
  • 299
  • 300
  • 301
  • 302
  • 303
  • 304
  • 305
  • 306
  • 307
  • 308
  • 309
  • 310
  • 311
  • 312
  • 313
  • 314
  • 315
  • 316
  • 317
  • 318
  • 319
  • 320
  • 321
  • 322
  • 323
  • 324
  • 325
  • 326
  • 327
  • 328
  • 329
  • 330
  • 331
  • 332
  • 333
  • 334
  • 335
  • 336
  • 337
  • 338
  • 339
  • 340
  • 341
  • 342
  • 343
  • 344
  • 345
  • 346
  • 347
  • 348
  • 349
  • 350
  • 351
  • 352
  • 353
  • 354
  • 355
  • 356
  • 357
  • 358
  • 359
  • 360
  • 361
  • 362
  • 363
  • 364
  • 365
  • 366
  • 367
  • 368
  • 369
  • 370
  • 371
  • 372
  • 373
  • 374
  • 375
  • 376
  • 377
  • 378
  • 379
  • 380
  • 381
  • 382
  • 383
  • 384
  • 385
  • 386
  • 387
  • 388
  • 389
  • 390
  • 391
  • 392
  • 393
  • 394
  • 395
  • 396
  • 397
  • 398
  • 399
  • 400
  • 401
  • 402
  • 403
  • 404
  • 405
  • 406
  • 407
  • 408
  • 409
  • 410
  • 411
  • 412
  • 413
  • 414
  • 415
  • 416
  • 417
  • 418
  • 419
  • 420
  • 421
  • 422
  • 423
  • 424
  • 425
  • 426
  • 427
  • 428
  • 429
  • 430
  • 431
  • 432
  • 433
  • 434
  • 435
  • 436
  • 437
  • 438
  • 439
  • 440
  • 441
  • 442
  • 443
  • 444
  • 445
  • 446
  • 447
  • 448
  • 449
  • 450
  • 451
  • 452
  • 453
  • 454
  • 455
  • 456
  • 457
  • 458
  • 459
  • 460
  • 461
  • 462
  • 463
  • 464
  • 465
  • 466
  • 467
  • 468
  • 469
  • 470
  • 471
  • 472
  • 473
  • 474
  • 475
  • 476
  • 477
  • 478
  • 479
  • 480
  • 481
  • 482
  • 483
  • 484
  • 485
  • 486
  • 487
  • 488
  • 489
  • 490
  • 491
  • 492
  • 493
  • 494
  • 495
  • 496
  • 497
  • 498
  • 499
  • 500
  • 501
  • 502
  • 503
  • 504
  • 505
  • 506
  • 507
  • 508
  • 509
  • 510
  • 511
  • 512
  • 513
  • 514
  • 515
  • 516
  • 517
  • 518
  • 519
  • 520
  • 521
  • 522
  • 523
  • 524
  • 525
  • 526
  • 527
  • 528
  • 529
  • 530
  • 531
  • 532
  • 533
  • 534
  • 535
  • 536
  • 537
  • 538
  • 539
  • 540
  • 541
  • 542
  • 543
  • 544
  • 545
  • 546
  • 547
  • 548
  • 549
  • 550

You can use vi or any other editor to create the .cmd
file,
then use the batch command to execute the
file.
To execute a series of
commands in a
file
in batch mode (non-interactive processing), use the
batch
command. OS10 automatically commits all commands in a
batch
file
— you do not have to enter the
commit
command.
Create a batch
file
(
b.cmd
) on a remote device by entering a series of commands.
interface ethernet 1/1/4
no switchport
ip address 172.17.4.1/24
no shutdown
Copy the command
file
on the remote device to your switch, such as to your home directory.
OS10# copy scp://os10user:[email protected]:/home/os10/b.cmd home://b.cmd
OS10# dir home
Directory contents for folder: home
Date (modified)
Size (bytes)
Name
---------------------
------------
------------------------------------------
2017-02-15T19:25:35Z
77
b.cmd
...
Execute the batch
file
using the
batch
command in EXEC mode.
OS10# batch b.cmd
OS10# Feb 15 19:26:1: %Dell EMC (OS10) %Node.1-Unit.1:PRI:OS10 %log-notice:IP_ADDRESS_ADD: IP
Address add is successful.:IP 172.17.4.1/24 added successfully
(Optional) Verify the new commands in the running
configuration.
OS10# show running-configuration interface ethernet 1/1/4
!
interface ethernet1/1/4
ip address 172.17.4.1/24
no switchport
no shutdown
Linux shell commands
You can execute a single command, or a series of commands using a batch
file
from the Linux shell.
Use the
-c
option to run a single command.
admin@OS10:/opt/dell/os10/bin$ clish -c "show version"
New user admin logged in at session 10
Dell EMC Networking OS10 Enterprise
Copyright (c) 1999-2018 by Dell Inc. All Rights Reserved.
OS Version: 10.3.2E(X)
Build Version: 10.3.2E(X.433)
Build Time: 2018-01-03T11:57:14-0800
System Type: S5148F-ON
Architecture: x86_64
Up Time: 1 day 05:34:06
User admin logged out at session 10
admin@OS10:/opt/dell/os10/bin$
Use the
-B
option along with a batch
file
to execute a series of commands.
configure terminal
router bgp 100
neighbor 100.1.1.1
remote-as 104
no shutdown
Getting Started
37