Cisco N7K-C7010 Configuration Guide - Page 274

Verifying the IP Tunnel Configuration, Configuration Examples for IP Tunneling

Page 274 highlights

Verifying the IP Tunnel Configuration Chapter 8 Configuring IP Tunnels Send document comments to [email protected] The following example shows how to add a tunnel interface to the VRF: switch# configure terminal switch(config)# interface tunnel 0 switch(config-if)# vrf member RemoteOfficeVRF switch(config-if)# ip address 209.0.2.1/16 switch(config-if)# copy running-config startup-config Verifying the IP Tunnel Configuration To verify IP tunnel configuration information, perform one of the following tasks: Command show interface tunnel number show interface tunnel number brief show interface tunnel number description show interface tunnel number status show interface tunnel number status err-disabled Purpose Displays the configuration for the tunnel interface (MTU, protocol, transport, and VRF). Displays input and output packets, bytes, and packet rates. Displays the operational status, IP address, encapsulation type, and MTU of the tunnel interface. Displays the configured description of the tunnel interface. Displays the operational status of the tunnel interface. Displays the error disabled status of the tunnel interface. Configuration Examples for IP Tunneling The following example shows a simple GRE tunnel. Ethernet 1/2 is the tunnel source for router A and the tunnel destination for router B. Ethernet interface 2/1 is the tunnel source for router B and the tunnel destination for router A. router A: feature tunnel interface tunnel 0 ip address 209.165.20.2/8 tunnel source ethernet 1/2 tunnel destination 192.0.2.2 tunnel mode gre ip tunnel path-mtu-discovery 25 1500 interface ethernet1/2 ip address 192.0.2.55/8 router B: feature tunnel interface tunnel 0 ip address 209.165.20.1/8 tunnel source ethernet2/1 tunnel destination 192.0.2.55 tunnel mode gre ip interface ethernet 2/1 ip address 192.0.2.2/8 8-10 Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 5.x OL-23435-03

  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 50
  • 51
  • 52
  • 53
  • 54
  • 55
  • 56
  • 57
  • 58
  • 59
  • 60
  • 61
  • 62
  • 63
  • 64
  • 65
  • 66
  • 67
  • 68
  • 69
  • 70
  • 71
  • 72
  • 73
  • 74
  • 75
  • 76
  • 77
  • 78
  • 79
  • 80
  • 81
  • 82
  • 83
  • 84
  • 85
  • 86
  • 87
  • 88
  • 89
  • 90
  • 91
  • 92
  • 93
  • 94
  • 95
  • 96
  • 97
  • 98
  • 99
  • 100
  • 101
  • 102
  • 103
  • 104
  • 105
  • 106
  • 107
  • 108
  • 109
  • 110
  • 111
  • 112
  • 113
  • 114
  • 115
  • 116
  • 117
  • 118
  • 119
  • 120
  • 121
  • 122
  • 123
  • 124
  • 125
  • 126
  • 127
  • 128
  • 129
  • 130
  • 131
  • 132
  • 133
  • 134
  • 135
  • 136
  • 137
  • 138
  • 139
  • 140
  • 141
  • 142
  • 143
  • 144
  • 145
  • 146
  • 147
  • 148
  • 149
  • 150
  • 151
  • 152
  • 153
  • 154
  • 155
  • 156
  • 157
  • 158
  • 159
  • 160
  • 161
  • 162
  • 163
  • 164
  • 165
  • 166
  • 167
  • 168
  • 169
  • 170
  • 171
  • 172
  • 173
  • 174
  • 175
  • 176
  • 177
  • 178
  • 179
  • 180
  • 181
  • 182
  • 183
  • 184
  • 185
  • 186
  • 187
  • 188
  • 189
  • 190
  • 191
  • 192
  • 193
  • 194
  • 195
  • 196
  • 197
  • 198
  • 199
  • 200
  • 201
  • 202
  • 203
  • 204
  • 205
  • 206
  • 207
  • 208
  • 209
  • 210
  • 211
  • 212
  • 213
  • 214
  • 215
  • 216
  • 217
  • 218
  • 219
  • 220
  • 221
  • 222
  • 223
  • 224
  • 225
  • 226
  • 227
  • 228
  • 229
  • 230
  • 231
  • 232
  • 233
  • 234
  • 235
  • 236
  • 237
  • 238
  • 239
  • 240
  • 241
  • 242
  • 243
  • 244
  • 245
  • 246
  • 247
  • 248
  • 249
  • 250
  • 251
  • 252
  • 253
  • 254
  • 255
  • 256
  • 257
  • 258
  • 259
  • 260
  • 261
  • 262
  • 263
  • 264
  • 265
  • 266
  • 267
  • 268
  • 269
  • 270
  • 271
  • 272
  • 273
  • 274
  • 275
  • 276
  • 277
  • 278
  • 279
  • 280
  • 281
  • 282
  • 283
  • 284
  • 285
  • 286
  • 287
  • 288
  • 289
  • 290
  • 291
  • 292
  • 293
  • 294
  • 295
  • 296
  • 297
  • 298
  • 299
  • 300
  • 301
  • 302
  • 303
  • 304
  • 305
  • 306
  • 307
  • 308

Send document comments to [email protected]
8-10
Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 5.x
OL-23435-03
Chapter 8
Configuring IP Tunnels
Verifying the IP Tunnel Configuration
The following example shows how to add a tunnel interface to the VRF:
switch#
configure terminal
switch(config)#
interface tunnel 0
switch(config-if)#
vrf member RemoteOfficeVRF
switch(config-if)#
ip address 209.0.2.1/16
switch(config-if)#
copy running-config startup-config
Verifying the IP Tunnel Configuration
To verify IP tunnel configuration information, perform one of the following tasks:
Configuration Examples for IP Tunneling
The following example shows a simple GRE tunnel. Ethernet 1/2 is the tunnel source for router A and
the tunnel destination for router B. Ethernet interface 2/1 is the tunnel source for router B and the tunnel
destination for router A.
router A:
feature tunnel
interface tunnel 0
ip address 209.165.20.2/8
tunnel source ethernet 1/2
tunnel destination 192.0.2.2
tunnel mode gre ip
tunnel path-mtu-discovery 25 1500
interface ethernet1/2
ip address 192.0.2.55/8
router B:
feature tunnel
interface tunnel 0
ip address 209.165.20.1/8
tunnel source ethernet2/1
tunnel destination 192.0.2.55
tunnel mode gre ip
interface ethernet 2/1
ip address 192.0.2.2/8
Command
Purpose
show interface tunnel
number
Displays the configuration for the tunnel interface
(MTU, protocol, transport, and VRF). Displays
input and output packets, bytes, and packet rates.
show interface tunnel
number
brief
Displays the operational status, IP address,
encapsulation type, and MTU of the tunnel
interface.
show interface tunnel
number
description
Displays the configured description of the tunnel
interface.
show interface tunnel
number
status
Displays the operational status of the tunnel
interface.
show interface tunnel
number
status
err-disabled
Displays the error disabled status of the tunnel
interface.